זאת עוד רשומה על פיירפוקס ואני מבטיח שהיא ממש מעשית ושימושית לכל הגולשים.


אחת הסיבות הנפוצות לכך שאנשים לא רוצים בכלל לשדרג את פיירפוקס היא שהתוספות השונות מפסיקות לעבוד בגרסה החדשה. יש שתי סיבות אפשריות לכך שתוספת לא תעבוד: הראשונה היא שהשתנה בפיירפוקס משהו שהתוספת השתמשה בו. במקרה הזה אין בררה אלא להמתין למפתח התוספת שיתקן אותה.

למרבה המזל, נפוצה בהרבה הסיבה השנייה: התוספת יכולה, למעשה, לעבוד, אבל היא לא מסומנת בתור תוספת שעובדת בגרסה החדשה. למקרה השני יש פתרון די קל: התוספת Add-on Compatibility Reporter. לכו לאתר הזה, והתקינו אותה. אחרי שתתקינו, תוכלו להתקין את כל התוספות ולהשתמש בהן בכל גרסה של פיירפוקס, כולל הגרסאות הניסיוניות העתידיות.

כמובן, התיקון הזה לא יעזור אם התוספת האהובה עליכם לא יכולה לעבוד בגרסה החדשה מסיבה אחרת, אבל זה, כאמור, המקרה הנדיר יותר. ואם זה בכל זאת קורה, אל תתביישו לכתוב למפתח התוספת ולבקש ממנו לתקן אותה – עשיתי את זה כבר מספר פעמים וכמעט בכל הפעמים התוספת תוקנה.

אז זהו, אינכם יכולים להגיד עוד „אני נשאר עם פיירפוקס, כי התוספת האהובה עליי לא עובדת בגרסה חדשה יותר”. שדרגו את פיירפוקס עכשיו.